Quesito O.T. Perché Java fa le bizze?

Il forum di Base5, dove è possibile postare problemi, quiz, indovinelli, rompicapo, enigmi e quant'altro riguardi la matematica ricreativa e oltre.

Moderatori: Gianfranco, Bruno

Rispondi
peppe
Livello 7
Livello 7
Messaggi: 840
Iscritto il: gio mag 26, 2005 1:41 pm
Località: Cirò Marina KR

Quesito O.T. Perché Java fa le bizze?

Messaggio da peppe » mer gen 22, 2014 1:33 am

Chiedo scusa a tutti coloro che non utilizzano il programma Java e ai basecinquini che
non amano le animazioni dinamiche, meglio note come applet, tipo ad esempio Geogebra, se
l'argomento non è pertinente col Forum. Mi rivolgo a voi con la speranza che alcuni
dubbi vengano chiariti, dal momento che, nonostante l'impegno e la fatica, non sono
riuscito a dissiparli in altro modo. Insomma vi sto chiedendo aiuto. Grazie

Incuriosito da questa citazione di panurgo:

[...]profittando del fatto che in un triangolo equilatero la somma delle distanze di un punto
interno dai lati è pari all'altezza del triangolo stesso (teorema di Viviani)
[...], che
ho letto qui e che ho verificato con questa animazione (dimostrazione senza parole), ho
voluto approfondire l'argomento e con l'aiuto di google sono finito qui.

Come potete constatare, la pagina dedicata al Viviani, si chiude così:

[...]Qui si può trovare, poi, una verifica del teorema di Viviani realizzata con Cabri da Paolo Lazzarini[...]

Dopo aver cliccato sul "Qui" linkato, grandissima è stata la mia delusione nel constatare che
anziché l'applet Cabri-Java, si è aperta una finestra con il seguente messaggio:
"Applicazione bloccata dalle impostazioni di sicurezza".
Ho attribuito l'anomalia a un difetto del sito ma senza convinzione.
Perciò ho voluto testare il programma Java con le numerose applet che si trovano in questa pagina: stesso risultato:
"Applicazione bloccata dalle impostazioni di sicurezza".

Qui vengono elencati gli avvisi di cui parlo.

Ora dovete sapere che rispetto all'informatica (e non solo a quella), io sono come
un cieco che brancola nel buio a tentoni e come il cieco, quando trova ostacoli, per
non finire a gambe all'aria, si aggrappa a qualsiasi appiglio.
Nella fattispecie gli appigli sono i blog di informatica che alcuni bravi volenterosi dedicano agli smanettoni imbranati come me.
Dopo essermi arrovellato il cervello per ben due giorni, ho trovato la soluzione.

Dal pannello di controllo java nella scheda avanzate, ho tolto il check dal
quadratino "abilita il plugin Java di nuova generazione" e poi ho riavviato il P.C.

Il plugin in oggetto è questo: Java 10.51.2.13-Uso della versione JRE 1.7.0_51-b13
e si riferisce all'ultima versione di Java, che da quanto ho potuto capire sta
dando fastidio anche con applicazioni tipo Geogebra.
Se il livello di sicurezza del pannello di "configure Java" è impostato su MOLTO Alto oppure ALTO,anziché BASSO, prima
di eseguire alcune applicazione tipo Geogebra Java chiede conferma avvisando che l'esecuzione
potrebbe danneggiare il computer.

Dpo questa lunga e noiosa premessa vi chiedo se anche voi (sono sicuro che le applet vi piacciono
e le utilizzate) avete riscontrato gli stessi problemi.
Preciso che abitualmente "navigo" col cargo I.E.-8 ma anche col "fulmine" Firefox ho avuto gli stessi inconvenienti.
Secondo voi:
1) E' pericoloso impostare un livello di sicurezza basso?
2) La disabilitazione del plugin Java potrebbe provocare danni?

Pongo queste domande perché stando a quel che dice l'autore di questa guida da
Java bisognerebbe stare molto ma molto alla larga. Saluti peppe.
«Un uomo è come una frazione il cui numeratore è quello che è, e il cui denominatore quello che pensa di sé.
Più grande è il denominatore, minore la frazione.» Lev Nikolàevič Tolstòj(1828-1910).

Rispondi